PrtSc + Cntl-V is OK.

But I found out today about ‘Snipping Tool’ built in to Vista, pretty much covers what you need to do.

  • Start->Snipping Tool (or create a shortcut on your quick launch)
  • Draw Square
  • Paste into Wherever
  • Done
Advertisements

Trying to install Basic Windows Authentication  AJAX application on local IIS 7 set up. 

This was previously only running on in built web server (is this called cassini?).

– Needed to TURN ON Windows Authentication IN the IIS Manager although this was also in the web.config.

 Got this error –

 Ajax Sys.Manager Error

 So naturally thought this was related to IIS 7 / modules / AJAX set up somehow.

 Found this – http://gramotei.wordpress.com/2007/08/17/aspnet-ajax-update-panels-and-responseredirect/ – but think this now out of date as redirect does work!

 Yet, it does just happen on redirect, so made me think IIS7 modules not set up, so, added –

  <modules>

            <add name=”ScriptModule” type=”System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″/>

 </modules>

to my <system.webServer> (which I found had to be in there for IIS 7 to work whilst trawling the web, I had already added a handlers section, but this was not enough)

Example full section ended up like this –

<system.webServer>

<handlers>

<add name=”ScriptResource.axd_GET,HEAD” path=”ScriptResource.axd” verb=”GET,HEAD” type=”System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ preCondition=”integratedMode,runtimeVersionv2.0″ />

<add name=”*_AppService.axd_*” path=”*_AppService.axd” verb=”*” type=”System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ preCondition=”integratedMode,runtimeVersionv2.0″ />

<add name=”*.asmx_*” path=”*.asmx” verb=”*” type=”System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ preCondition=”integratedMode,runtimeVersionv2.0″ />

</handlers>

<modules>

<add name=”ScriptModule” type=”System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″/>

</modules>

<defaultDocument>

<files>

<add value=”index.aspx” />

<add value=”index.asp” />

</files>

</defaultDocument>

</system.webServer>

Hi,

I have various dev virtual machines, and finally thought I’d stick sql 2005 on my main machine.

I came across this error when trying to put full text indexing on a table –

Execution of a full-text operation failed.  ‘The dependency service does not exist or has been marked for deletion’

 

 

 

I followed the various links below, agonised, messed about, ate a pie, then realised that I had not put SP2 on!!!!!! (as I installed SQL a few weeks ago and clearly forgot this vital last step)

http://geekswithblogs.net/Saqib/archive/2007/03/16/sql-server-full-text-search-service-running-problem-in-windows.aspx

 

http://www.linux-watch.com/news/NS4434907782.html

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2972899&SiteID=1

Hi All,

Tried access the main betfair site via iphone safari! proceeded to crash and reset the phone when entering the soccer section.  I then proceeded to find –

https://iphone.betfair.com (remember the https)

Think its still in early stages, but it does a great job of a cheeky ‘£10 on the nose’ when out and about!

– Could do with ‘my favourite markets’ section, like main site
– Could do with remember my login settings (yes, we know its a potential security risk, but its upto me NOT to lose my phone surely?)
– I also want to view the markets before logging in

After installing Visual Studio 2008 SP and .NET Framework 3.5 SP1 I tried to create and run a quick dynamic data test site and got at least the following errors –

Error 3 ‘System.Web.DynamicData.FieldTemplateUserControl.Mode’ is not supported by the language C:\Users\matt\Documents\Visual Studio 2008\Projects\DDWebApplication\DDWebApplication\DynamicData\FieldTemplates\ForeignKey_Edit.ascx.cs 37 17 DDWebApplication

Error 5 ‘System.Runtime.Serialization.DataContractAttribute’ does not contain a definition for ‘IsReference’ c:\users\matt\documents\visual studio 2008\projects\ddwebapplication1\ddwebapplication1\model1.designer.cs 286 65 DDWebApplication1

Warning 1 Reference to type ‘System.Web.UI.WebControls.DataBoundControlMode’ claims it is defined in ‘c:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Web.dll’, but it could not be found c:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Web.DynamicData.dll DDWebApplication1

To cut a very LONG (and brain aching) story short, my installation BELIEVED it had installed correctly with no error messages, BUT it simply had not upgraded .net framework 3.0 and 3.5 to the appropriate SP2 and SP1!!

The only way to fix this (re-installing over the top was no good) was to uninstall (when doing this you will notice that hotfixes et al are not installed in the first place) and reinstall as per this excellent guide from Aaron Stebner (who suggested this in the 1st place) –

http://blogs.msdn.com/astebner/archive/2008/08/01/8803442.aspx

If this is not your issue, here ‘some’ are Other links I travelled through in trying to fix this –

http://blogs.msdn.com/astebner/archive/2008/06/24/8649874.aspx
http://forums.microsoft.com/msdn/ShowPost.aspx?PostID=3533510&SiteID=1
http://forums.microsoft.com/msdn/ShowPost.aspx?PostID=3610934&SiteID=1
http://social.microsoft.com/Forums/en-US/whatforum/thread/d8d5bb5c-d3b1-4152-89b2-eabe306ca0bc/
http://blogs.msdn.com/astebner/archive/2008/03/03/8015158.aspx

Hope this helps save someone some grief!